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General improvements

Texts

A text string can
be associated with
objects such as
po in t s ,  l ine s ,
p o l y g o n s  o r
surfaces, via the
O b j e c t  I n f o
palette. To create
a text object, select
the Point tool in
the Tool palette
(1) and click in the
drawing  a rea
where the text is
to be located (2).
While still being
selected, write the
desired text in the Object Info palette (3). Press Enter or TAB to transfer the written
text to the object (4).

Texts are displayed close to the green Starting Point dot, but can be moved by the
Flip Index Direction commands in the Edit menu.

The text editing features are available both under the
Dimension and Properties tabs in the Object Info palette,
with identical functions. Each text can use its own font, size
and style settings, for example Bold, Italic or     Underline   .

Texts have individual options to be visible in the drawing
area, and/or in the object spreadsheet. The setting is controlled
in the Object Info palette using the Hide checkboxes. The Text
box is used for hiding texts in the drawing area, the ID box for hiding object ID’s in
the drawing area irrelevant for material specifications, and the DB box is used for
excluding the item concerned from the object spreadsheet. Un-checking Show 3D
Object ID and/or Show Texts can exclude texts and IDs from the drawing area in the
View menu. Texts can also be seen in the Unfold view close to the starting point, and
in combination with the Object IDs, by checking the option in the View menu -> Show
In Unfold -> Text Database.
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Each object and consequently text can be displayed in 3D
and hereby follow the view and object location when
rotated in space. A text can also be associated with a fixed
view such as Front, Top or Side and only be shown in the
given view.  The text can also be treated as a strict 2D object
regardless of view but where editing and selection of objects
are restricted to the Front fixed view only.

Texts can also be seen and edited in the Spreadsheet in
menu -> Tool -> Surface Properties -> List All Objects. To
edit the text in the spreadsheet, click on the relevant text
field and enter the new text in the entering field. The updated text is automatically
transferred back to the drawing and updates it.

Material and labor costs

Material and labor time/costs can now be specified in the
Object Info palette. Such data are then compiled and summed
in the database spreadsheet (menu->Tool->List All Objects).

Measurements

Measurements can be added as an
associated part of a line or polygon
object. It can either be done using the
Measure tool, with the Dimension
Line option checked in the Mode
bar, or by simply clicking on either
of the two dimension buttons in the
Object Info palette. These two
buttons control if the measurements
is to be displayed as an accumulated
polygon length or as a chain
measurement with measurements for
each segment.

Measurements are always three-dimensional in method and by stated dimensional
values. Measurements has the same view settings as texts and objects, meaning it can
be viewed in full 3D, be associated with a given view, or be strictly two dimensional
displayed from any view.

Measurements can be displayed individually using arrowheads, cross lines or by dots.
The settings are located in the Object Info palette.

Measurements can now also be displayed as coordinate measurements in 3D, similar
to what was previously available in the Unfold view. In 3D though, such measurements
are clicked out manually using the Measure tool and selecting the Coordinate mode in
the Mode bar. When this tool setup is activated, it is recommended that you first
position a local origin point, click out the relevant measurement lines, and then reset
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the origin. In such a way, it is possible to add measurements for several objects in the
same drawing area, and using local coordinate systems for each object.

Instructional arrows

Line and polygon objects can also have arrow / cross / dot
elements at each respective end. Clicking on the respective
start and end buttons in the Object Info palette activates the
feature. The marker type is also selected in the Object info
palette.

Shaded surfaces

Surface objects can be displayed with a shaded surface based on the fill color. Such a
setting is individual for each object as it is primarily intended as a drawing aid and not
as a supplement to the Rendering mode. The shading is displayed on objects with
Display mode set to “Mesh with…” in the Object Info palette, Properties tab, Display
Mode pop-up.

The shading can be controlled further using the Surface Shading options in the View
menu. The Wireframe option turns off the shading altogether. Fast Shading skips
component sorting, and therefore works quicker. Flat Colors use the exact color as
defined in the Color palette, without compensating the color for light effects. Dynamic
Shading recalculates the shading dynamically when rotating view or deforming the
model, which may be slow on more complex models but gives a more dynamic
impression of how the model would look like.
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Tool palette

Improvements in the Tool palette:

Rotate tool, twist.

The Rotate tool works as before, except for the Twist mode available in the Model bar.
When using the Twist mode, the model is twisted based on the location away towards
you in the used view. The lower coordinate value, the lower degree of twist.

Measure tool, Tape Measure

Besides the Tape measure mode, which works as before, the Mode
bar now contains modes for drawing measurement lines and
coordinate measurements.

Measure tool, Measurement lines

The Mode bar for the Measurement tool also contains a mode
for drawing measurement lines. It basically works like the
Polygon line, but also adds measurements by default.

Measure tool, Coordinate Measurements

The Mode bar for the Measurement tool also contains a mode for drawing coordinate
measurements. Select the
Measure tool (1), Coordinate
mode in the Mode Bar (2).
When using the Coordinate
Measurement mode, two
additional buttons occur for
setting and resetting the
drawing origin. With Set
Origin (3), you click on a
given location to set the
origin (4). With Reset Origin
(6), you simply click on the button to reset the origin to the default location.  Once the
origin has been set, click on a given location (5) and the drag the text to a suitable
location and click again.
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Line tool.

The Line tool now always generates a control ruler.

Rectangle tool.

The Rectangle tool provides two basic modes,
Rectangle and Rounded Rectangle, which adds a
radius to each corner when drawn. When Rounded Rectangle mode is activated, an
additional button is displayed, which when clicked on, displays a dialog used for
entering a radius.

Each of these object types can be generated either as a single control ruler, or as a
surface defined by two connected rulers.

Circle / Ellipse tool.

The Circle / Ellipse tool can be generated either as a
single control ruler, or as a surface defined by two
connected rulers. Three different drawing methods
are available in the Mode bar, circle by three points, by diameter, or by radius.

Polygon tool.

The Polygon tool generates control ruler either defined as a
polygon, with straight lines between the control points, or as a
smooth curve. The options are located in the Mode bar.

Arc  tool.

The Arc tool can either generate a single control
ruler or a surface defined by two connected rulers.
Two different drawing methods are available in the Mode bar, by radius, or by three
points.
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Menus

Improvements in the menu commands are as follows:

File menu.

Save Selection as…

The Save Selection As command saves selected objects in a new separate file for later
use. Such files can for example be imported and reused as components in other models
using the Load Into command.

Export as DXF...

Unfolded panels can now contain the
object database texts next to the object ID
text. The support for the AAMA standard
used in the textile industry has been
improved. The AAMA support includes
exporting from the 3D view as a 2D
projection, using special color names that
are exported as AAMA layers. These are
1_Cut, 4_Notch, 8_Draw, 11_Incut,
13_Drill, 19_Text, and 26_Ref. When
exporting as AAMA in 3D, all other
colors are ignored. Also worth noting is
that selected parts can be re-exported
from the Unfold view back to 3D for after
processing, using the contextual menu (in
the Unfold view, right-click and selecting
Unfold to 3D).

Export as STL…

The Export as STL command has been updated. Note that normals (menu -> View ->
Show Normals) can now be displayed to indicate the inner and outer side of a given
panel.
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Edit menu.

Control Point Resolution.

The Control Point Resolution now
supports a local mode, where the
distribution only takes place in the
control ruler being in possession of the
Intersection Point symbol, and in between
the lowest and highest indexed ones of
selected points. If, for example points
number #3 & 7 are fixed points that
should remain at it’s original location,
you can select points 3-7 and then
redistribute them internally, without
affecting the points with indexes below #
3 and above #7.

Page menu.

Set Grid.

The Set Grid command has been integrated into the Units dialog.

Units…

The Units dialog has been extended with
separate units and rounding settings for
database lengths (edge lengths), drawing
units (used to be Set Grid), area units,
volume units, weight units, and
measurement units (used in measurement
texts) (1).  An edit field for water density
has been added with a default value for
salt water (3). Settings for arrowhead dot
and cross line sizes have been added (2).



9

Sectioning Settings.

In the Sectioning Settings dialog, it is now possible to set the set the general
background color for the drawing area.

Tool menu.

Add End Cap2.

Add End Cap2 is an alternative method
to Add End Cap, which divides the
edge into two control rulers that are
connected. Add End Cap takes the
entire edge length and connects it to a
midpoint control ruler. Which of these
two methods that works best on a given situation depends on what the goal of the new
surface is.

Surface Properties -> List All Objects.

The List All Objects dialog has been extended substantially and now contains the
database information of the objects in the drawing area. Specifications include data
type (1), index number (1), text (2), weight and weight per area units data (3), surface
area, center of gravity (4), layer (5) and color identities (6), 3D edge (8) and unfolded
panel edge lengths (7), and estimated labor time (10) and material costs (9). Many of
these settings are double acting (text, weights, center of gravity, layer, color, labor time
and material costs), and can therefore be changed (12/13) and be updated (14) either in
the drawing area / Object Info palette, or in the List All Objects dialog. Objects can
also be selected (15) from the List All Objects dialog, and if needed, be removed from
the database (16) (e.g. measurement lines and drawing head labels, which are not
strictly parts of the physical project).
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Triangle…

The Triangle dialog creates a triangle based on
three given lengths.

View menu.

Surface shading.

The shading can be controlled further using the Surface Shading options in the View
menu. The Wireframe option turns off the shading altogether. Fast Shading skips
component sorting, and therefore works quicker. Flat Colors use the exact color as
defined in the Color palette, without compensating the color for light effects. Dynamic
Shading dynamically recalculates the shading when rotating view or deforming the
model, which may be slow on more complex models but gives a more dynamic view of
how the model looks.

Show Normals.

The Show Normals option displays a small
line and ring away from the starting point of a
surface, and facing the outer side. This feature
is important when exporting .STL files, which
must contain closed shapes with normals
facing outwards. If a given surface is faced
wrong side out, it can be corrected using the
Flip Index Direction commands in the Edit menu.

Zoom Line Thickness.

With the Zoom Line Thickness option checked, TouchCAD displays the line
thicknesses in the drawing area. Note that the line thickness can be set individually in
the Object info palette, Properties tab, Line (thickness) pop-up.

Show Texts.

With the Show Texts option checked, database texts are being displayed in the drawing
area.

Show in Unfold -> Database Texts.

With the Database Texts option checked, database texts are being displayed in the
drawing area when the Unfold view is selected. The texts occur after the object ID’s.
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   Show in Unfold -> Material Stretch Compensation.

In the Material Stretch Compensation dialog, compensation factors can be added to the
unfolded parts. If the know stretching is 1% along the material direction, you simply
compensate this direction by entering a factor of 99%. Compensation can be set
individually along the material direction as well as sideways.
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Contextual menus

The number contextual menus have been increased to speed up various processes and
in order to reduce the number of tool changes. Note that the menu features vary in
occurrence and location in the menus depending upon if something is selected or not,
and whether the cursor snaps to a control point or not. Contextual menus, if any,
appear when right clicking on the relevant object, or by pressing the Control key and
left clicking.

Drawing area 3D

Select All.

Selects all objects being accessible due to layer settings.

Deselect All.

Deselects all objects being selected.

Undo.

Reverts the last action.

Redo.

Reverts the last undo action.

Render Model.

Turns on the Render mode.

Fit to Window.

Changes the degree of zoom and pan to make the paper size fit into the screen.

Drawing scale.

Changes drawing scale to make a model fit into the drawing area. Note that
TouchCAD models are always defined in full-scale measurements, and the drawing
scale adapts it to the paper area used.

Rotate.

Changes the tool setting to Rotate temporarily, allowing a rotation sequence and then
returns to the previously selected tool. The command is only displayed when an object
is selected.

Mirror and Mirror and Duplicate.

Changes the tool setting to Mirror / Mirror and Duplicate temporarily allowing a
mirror sequence, and then returns to the previously selected tool. This command when
only displayed if an object is selected.
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Select…

Select -, Object, -Points along Ruler, -Points Perpendicular to Ruler, -Edge Points all
behave as the equivalent means in the Edit menu. The commands are only displayed if
an object is selected or if a point snap instance has occurred.

Combine Into Curve.

Combines selected points into a curve, starting from the point owning the Intersection
Point symbol. The command behaves in the same way as the equivalent command in
the Tool menu. The command is only displayed when an object or some control points
are selected.

Add Control Point.

Add Control Point adds a control point along a control ruler and in a direction away
from the green starting point dot. The command behaves in the same way as the
equivalent command in the Tool menu. The command is only displayed when at least
one control point is selected.

Add Control Ruler.

Add Control Ruler adds a control ruler, and in a direction away from the green
starting point dot. The command behaves in the same way as the equivalent command
in the Tool menu. The command is only displayed when at least one control point is
selected.

Extract Ruler.

Extract Ruler extracts a copy of control
ruler from a surface object. The
command is only displayed when at
least one control point is selected.

Extract Cross Curve.

Extract Cross Curve extracts a copy of
cross curve from a surface object. The
command is only displayed when at
least one control point is selected.
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Connect Rulers with Surface.

Connects two rulers in for example two different surfaces with an intermediate surface.
Works on edges as well as
intermediate objects to create a
bulkhead. The command requires
snap clicking on a control point in
each ruler.

Connect Cross Curves
with Surface.

Connects two cross curves in for
example two different surfaces with
an intermediate surface. Works on
edges as well as on intermediate
objects to create a bulkhead. The
command requires snap clicking on a control point in each ruler.

Add Guide Line.

Add Guide Line adds a guideline away from for example a measurement line to the
actual measuring point. The command requires snap clicking on a control point as a
first sequence step.

Control Point resolution.

Works exactly as the Control Point Resolution command in the Edit menu, but can be
activated on non-selected objects if the cursor shows a point snap indication.

Redistribute Controls.

Works exactly as the Redistribute Controls command in the Edit menu, but can be
activated on non-selected objects if the cursor shows a point snap indication.

Duplicate.

Works exactly as the Duplicate command in the Edit menu, but can be activated on
non-selected objects if the cursor shows a point snap indication.

Extrude.

Works exactly as the Extrude tool in the Tool palette. However note that the Extrude
tool is only activated temporarily, and is reset to the original tool when the sequence is
completed.
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Drawing area, unfold view

Rotate.

The Rotate tool is chosen in the Tool palette, performs the rotation sequence and then
returns to the original mode automatically. The method provides a more precise and
controllable rotation than when using the scale box rotation.

Rotate Left / Right 90 degrees.

Rotates selected panels 90 degree to the left or right.

Rotate min Height/Width.

The Rotate min Height (1B / Width (1C) command locates the lowest possible height /
width by rotating the panel. Useful when doing panel nesting work in order to prepare
the panels for cutting.

Stack Horizontal/Vertical.

Stacks selected panels horizontally or vertically based on the boundary box of each
object, and make a good base for more detailed panel nesting (2B).

Align Top/Bottom/Left/Right.

Aligns selected object sides with the selected side (3C).

Unfold to 3D.

The Unfold to 3D command makes a copy of the unfolded panel cut and joining
panels, object ID’s and text and move them back to the 3D Front view. The primary
use for the feature is to allow after processing of unfolded panels, for example
additional markings, on-surface holes or markings, etc.
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Rendering area

Wireframe.

Brings back the normal drawing area.

Standard views.

Displays a chosen standard view in rendering mode.

Rendering to Background Image.

Makes a screen dump of the rendered view as seen on the screen and transfers it to a
chosen background image location. The displayed dialog allows you to choose a view
location, and also indicates if the spot is used (red dot) or not (green). The purpose of
the command is primarily to add an illustration to the drawing in order to clarify a
given shape. Worth noting is that the version 3.6 prints background images as a part of
the drawing.
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Languages

TouchCAD is now available in English, French, Italian, Spanish and Swedish.

Technical data

TouchCAD needs Mac (OSX 10.3–), or Windows (XP / Vista). 1 G RAM, 1 GHz
processor or better. QuickTime and OpenGL installed. USB port. Tutorial movies are
included on the program CD.
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